Salome wayland session not opening debian/ubuntu based system

I am facing the same issue as mentioned here:

having the same error message when I run ./salome (or ./mesa_salome)

X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 3 (X_GetWindowAttributes)
Resource id in failed request: 0xe
Serial number of failed request: 10
Current serial number in output stream: 11

is there any solution that does not involve fall back to X11 for the hole system?
(also for extra info, my sat output is OK for everything)
this is happening with the ubuntu specific. I just tested with the universal, in this case it works with the exception of the explode function in GEOM

Hello Franco,

to make Explode work, try to add these extra libraries extra_libs.tgz (1,2 Mo) for the universal binaries.

Extract them in SALOME-9.12.0/BINARIES-CO7 and add in salome after system_dep:

    context.addToLdLibraryPath(out_dir_Path + r"/BINARIES-CO7/extra_libs")


Hello christophe,
thanks for your help, this solved the problems with explode function, just a small detail for others that might have the same issue there is a missing “/” in the line of code to add the correct line is:
context.addToLdLibraryPath(out_dir_Path + r"/BINARIES-CO7/extra_libs")
and to insert directly in the correct location (for new users out there)

cd $salome_folder
sed -i 's|# context.addToLdLibraryPath(out_dir_Path + r"/BINARIES-CO7/system_dep/gl")|# context.addToLdLibraryPath(out_dir_Path + r"/BINARIES-CO7/system_dep/gl")\n    context.addToLdLibraryPath(out_dir_Path + r"/BINARIES-CO7/extra_libs")|' "./mesa_salome"


Thank you Franco for the feedback. I have added the missing / to my message.


1 Like