not working but all dependencies found

I have uploaded the output here:

Further, this is happening on another desktop I have again with Ubuntu 22.04. It seems to not find

which is locally at /usr/lib/x86_64-linux-gnu/ Creating a symbolic link to this removes the error in the ldd output but does not fix the problem.

apologize for the late reply. Using the universal 9.8.0 binary, I managed to run SALOME on an Ubuntu 22 and did the basic following test in GEOM:

  • create a box
  • explode operation

Enclosed the list of what is installed on the UB22 I used to check. You can use this list and check if some packages are missing on your side.
UB22.txt (219.6 KB)

Thanks for the reply. I am confused as to how you are able to run it. I had no problems, but an Ubuntu update must have broken it. There are so many packages it would be crazy to try and install everything you have that I don’t. I have outputted my installed packages and used comm to find the ones you have that I don’t, which are many. The obviously relevant one in this case is the libselinux1 and libselinux1-dev which we both have the same version.

I have fixed the problem with and the output of ldd shows now finds it in the appropriate system directory. Now, the output of ldd does not have any shared objects it cannot find. Yet, explode still does not work.

Could you perhaps share the output of the ldd on Is there anything else that could be at fault?


Enclosed the file which lists output of ldd and output of apt-file find for these shared objects.
libEntityGUI.txt (30.5 KB)

lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 22.04 LTS
Release:	22.04
Codename:	jammy

Thanks for the additional info. I have confirmed I have all the relevant packages as per your output, and on a fresh copy of SALOME-9.8.0 I mimic your ldd output except for the, which has the line:

BINARIES-CO7/GEOM/lib/salome/ /home/chris/Desktop/SALOME-9.8.0/BINARIES-CO7/system_dep/ no version information available (required by /lib/x86_64-linux-gnu/

I can remove this error by copying the file /lib/x86_64-linux-gnu/ to the system_dep directory, replacing the original one that ships with SALOME. However, explode still does not work after this.

The relevant object that needs is, which is not shipped with SALOME, but is installed on my computer. This is the same package as you have.

Thus, I really do not know how it is working on your end but not mine…

Do you have any other thoughts?



We are going soon to support UB22 with SAT. In the meanwhile, a last try would be that we do it the other way around: upload the list of installed packages and we can check if something can be spotted.

Dear all,

I encountered the same [from 2D sketch to surface from face / explode…] error.
the info. of items included the Salome 9.9.0 universal on Ubuntu 22.04.

all of libraries were normal from [ldd …]

should I re-install the Ubuntu20 as a reasonable way ???

Thanks. Plz help me.

Can you try to just remove the file BINARIES-CO7/system_dep/ ?

Hello everyone! I have the same porblem with universal packages for SALOME 9.10.0 and Ubuntu 22.04.1 LTS.
Unfortunately nothing helps me. The check for libEntityGUI shows me that all needed libraries were installed.
Anybody knows what else we can do to fix this very strange problem?

I am using universal Salome 9.9.0 on Arch and got the same issue.

can you either try the Ubuntu 22.04 version of SALOME platform or simply share the output of apt list --installed such that we can check what is missing?

I’m not familiar wirh Arch. Could you share the OS version as well as the list of installed packages on your distro?
With these informations, we could check if we reproduce your issue.

Yes, of course

apt_list_installed.txt (155.6 KB)

Hello, sorry for the delay. I am using EndeavourOS (based on Arch) is rolling release. It does not have a major version. The installed packages are as follows:

packages.txt (5.3 KB)

Good evening, dear @NabilG ,
I must say that everything is OK with Explode when I use the Ubuntu 22.04 version of SALOME platform. But I’m still interested in reason of Explode breaking in universal binary version (because I’m fighting with the similar problem for older version of SALOME).
According to the source code from Git, libEntityGUI is the only one library for Explode instrument, if I’m not mistaken. All dependencies are resolved, therefore, everything must be OK… but it does not. Maybe it requires some exact versions of libraries? How to check it?

apologize, we did not have time to look into this so far. I understand that you get things right with native ubuntu 22.04 build. We need on our side to be able to reproduce the reported issue first.

The problem persists with Salome 9.11.0 too. Once “” deactivated, all dependencies seem available for “”… If you found solutions, please share them.

I am facing the same issue with tuxedOS which is based in last release of Ubuntu, with salome 9.11 universal. as the OP i have all the libraries, and furthermore I tried by removing the still the same issue the explode feature does not work in the GUI. oh and the ubuntu 22 vr gives me an error the ./salome and the ./mesa_salome

ERROR:salomeContext:Unexpected error:
Traceback (most recent call last):
File “/home/franco/SALOME-9.11.0-native-UB22.04-SRC/BINARIES-UB22.04/SALOME/bin/salome/”, line 294, in _startSalome
res = getattr(self, command)(options) # run appropriate method
File “/home/franco/SALOME-9.11.0-native-UB22.04-SRC/BINARIES-UB22.04/SALOME/bin/salome/”, line 381, in _sessionless
import setenv
File “/home/franco/SALOME-9.11.0-native-UB22.04-SRC/BINARIES-UB22.04/KERNEL/bin/salome/”, line 26, in
from launchConfigureParser import verbose
File “/home/franco/SALOME-9.11.0-native-UB22.04-SRC/BINARIES-UB22.04/KERNEL/bin/salome/”, line 31, in
from salome_utils import verbose, getPortNumber, getHomeDir
File “/home/franco/SALOME-9.11.0-native-UB22.04-SRC/BINARIES-UB22.04/KERNEL/bin/salome/”, line 39, in
import psutil
any help will be apreciated

Hello here is the solution to this issue: