How to build Shaper in Window 11


I’m new to Salome. I tried to get Shaper project and build it in Window 11. It sounds to me that I should be able to do it by run “build_Salome_rel.bat” or “build_Salome_deb.bat”. However, neither of them worked.

Then I took a quick look at “build_Salome_rel.bat”:

REM Find absolute path to ROOT_DIR
pushd %PARENT_DIR%


call %SRC_DIR%\env_Salome.bat

Basically I could not find the “sources” folder in Salome, neither “env_Salome.bat”.
Did I miss anything? In order to setup the development environment for the shaper project, what else need to be downloaded?

Thanks in advance for your inputs.

Best regards!

better proceed as follows (not tried on Windows 11 - so we welcome feedback):


  • git installed and in you PATH
  • visual studio 2017 community edition installed


  • start a cmd terminal and create a directory, say: C:\S

  • in a directory, e.g. C:\S, extract SALOME 9.9,

  • copy the attached Batch script SALOMEConfigTool.bat to C:\S

  • run the script as follows :
    call SALOMEConfigTool.bat --application SALOME-9.9.0

  • in SAT, apply the attached patch sat_system.patch aimed to use rmdir

  • setup Visual studio environment by typing:
    call "C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Auxiliary\Build\vcvarsall.bat" x64

  • clone the SHAPER and CONFIGURATION modules as follows:

cd C:\S
SALOME-9.9.0\W64\Python\python.exe SAT\sat prepare SALOME-9.9.0 -p SHAPER,CONFIGURATION
  • compile SHAPER with the following command line:
cd C:\S
SALOME-9.9.0\W64\Python\python.exe SAT\sat compile SALOME-9.9.0 -p SHAPER,CONFIGURATION --clean_all

Attached the batch script and the patch to be applied to SAT:

SALOMEConfigTool.bat.txt (6.6 KB)

sat_system.patch.txt (1.2 KB)

Nabil, Thank you very much for your information. I could proceed these steps successfully until the last one. I failed to compile shaper with following error message:
D:\Salome>SALOME-9.9.0\W64\Python\python.exe SAT\sat compile SALOME-9.9.0 -p SHAPER,CONFIGURATION --clean_all
Executing the compile commands in the build directories of the products of the application SALOME-9.9.0
SOURCE directory = D:\Salome\SALOME-9.9.0\SOURCES
BUILD directory = D:\Salome\SALOME-9.9.0\BUILD

Compilation of CONFIGURATION … ignored
Compilation of SHAPER … ERROR : the following mandatory product(s) is(are) not installed: Sphinx

It sounds like that Sphinx is not installed. Should I install it previously?


for that release, you need to run:

SALOME-9.9.0\W64\Python\python.exe SAT\sat compile SALOME-9.9.0 -p Sphinx

followed by:

SALOME-9.9.0\W64\Python\python.exe SAT\sat compile SALOME-9.9.0 -p SHAPER --clean_all

  1. cmake
    chcp 65001
    @REM salome path
    set salome_root_dir_=E:/Code/SALOME/SALOME_MECA/v2023

@REM env_launch.bat evn path .I use the official installation program.
call ./env_launch.bat

set CONFIGURATION_ROOT_DIR=E:/Code/SALOME/Code/configuration

@REM override omniORB
set OMNIORB_ROOT_DIR=E:/3rdEnv/Salome/omniORB
set PATH=E:/3rdEnv/Salome/omniORB/lib/x86_win32;%PATH%
@REM set PATH=C:/Users/liyun01/Desktop/omniORB/lib/x86_win32;%PATH%
set PYTHONPATH=E:/3rdEnv/Salome/omniORB/lib/python;%PYTHONPATH%
set PYTHONPATH=E:/3rdEnv/Salome/omniORB/lib/x86_win32;%PYTHONPATH%


@REM set buildDIR=build
if exist ./build2 (
rmdir /s/q build2

mkdir build2
cd build2


  1. configuring down and error

    I guess it’s a problem with SIP that didn’t generate these files

build in windows10

i’m build salome meca.and i Successfully compiled kernel .

archive ?I’m confused. Is it starting from the file downloaded from Git?

Are you building SALOME or SALOME Meca?
You can first check whether you can build GUI starting from a SALOME archive following the steps described in this thread.

1 Like

i find you update sat_salome.I cannot download these projects,RESTRICTED SALOMEBOOTSTRAP OPENTURNS_SALOME pmml CEATESTBASE. Can you provide the correct git address?

see my reply in other thread. Some modules are not mirrored to gitpub on purpose.
Here, comment out RESTRICTED, CEATESTBASE. Other projects can be found in SALOME Linux archives which embed sources.

I believe this will be fixed in the near future.