Explode not working salome9.12

On Ubuntu 22 using universal salome 9.12 but the explode feature creates problem. It says gui library for explode not found. I tried the fix below but it doesn’t work.

Curiously it works on windows but i cant get parallel meshing to work on windows.

Please help how to get it working on ubuntu 22


Did you follow all the steps? Modifying the mesa_salome/and or Salome file to add the corresponding line? Did you extract correctly into the correct folder the missing library? Give more details don’t say “it doesn’t work” we need to guess from this phrase what is the problem in a 9 gb program…
for parallel meshing in the release notes, in the example script and also the script it even prints out a message in windows, parallel meshing does not work in windows.

Thanks for the reply.
Yes I did as stated. I will try again soon and report the output.

Anirudh Nehra

I tried it this way. I extracted the archive in a folder on deslktop called salome_latest and then following code I first used sed without -i to see if there is some editing done. Then sed -i to overwrite “mesa_salome” file. Yet it does not work and I get attached error.
I attach the log as it surpassed character limit here.
ubuntu_log.txt (81.5 KB)

Please help.
Thanks and regards
Anirudh Nehra

You need to add the extra_libs folder inside BINARIES-CO7/extra_libs and send it to there in mesa_salome. Have a look in the linked comment inside the linked comment that you linked in the first post.