Error loading plugin NETGENEngine.dll

I am trying to do the meshing with Salome but I get this error:

Can’t load mechers plugin library NETGENEngine.dll

can you share the folder PATH in which you installed SALOME ?

we have a zip version and no installations were made in the PATH folder, I attach a screenshot.

From the screen capture you shared, I can see that you do have Python3.10 in your PATH, which can be problematic. Here, you need to:

1/ install SALOME in a a folder which name is not too long, like e.g. C:\SALOME-9.9.0

2/ in order to avoid conflicts between your Python 3.10 and the one embedded with SALOME, you need to patch the run_salome.bat launcher as follows:

a)- start a cmd and type : echo %PATH% to retrieve the PATH environment variable content.

b)- edit file run_salome.bat, and right before:

START %out_dir_Path%\W64\Python\python3.exe %out_dir_Path%\salome %*

add to PATH the output of a) without any reference to C:\User\User\AppData\Local\Programs\Python:

SET PATH= output of step a) without references to C:\User\User\AppData\Local\Programs\Python.


Tried in the run_salome file.bat add everything from path, except everything related to python. Also in PATH, the version was changed from 310 to just Python. Attached photo

Another photo

there is a space between SET PATH= and % which needs to be removed.
you can also remove the path which is in cyrilic in case.
then simply double click on run_salome.bat and let us know if it helps. hth

It didn’t help. Removed the space bar and tried to run as administrator… does not work :frowning:

hard to guess. so:

  • where did you install SALOME 9.9.0, in C:\SALOME-9.9.0 ?
  • Is NETGENEngine.dll present in directory: SALOME-9.9.0\W64\NETGENPLUGIN\lib\salome ?
  • can you run the following commands and upload the output txt file:
    • double click on run_salome_shell.bat, this will launch a terminal with SALOME environment set
    • then type: echo %PATH% > myenviron.txt
    • then type: env >> myenviron.txt

Ensure that in that file, you don’t have sensitive information which SHOULD not be shared on this forum, and if this is the case, remove it, and upload the file, such that we can have a look.



Thanks! I’ll answer you tomorrow.

Good afternoon!
myenviron.txt (4.4 КБ)

Can you edit run_salome.bat and right before:

START %out_dir_Path%\W64\Python\python3.exe



and restart SALOME

It doesn’t help… Here’s what error comes out in the console

This PC is located in the domain and the program is installed on behalf of the local administrator

well, then I don’t know.
I just installed SALOME 9.9 as administrator and ran as a normal user and it is fine.
Here is what you can do to check that you do not have some missing library:

  • download Dependencies-walker
  • launch run_salome_shell.bat
  • in that shell start DependenciesGui
  • in the dependencies GUI, window, upload the NETGENEngine.dll to see if some dependencies are broken (see screen capture below)

If someone else has some ideas, he/she might give some tips.

Hi! Thanks for the help, but unfortunately, nothing helped. I think the problem is in the Python version. So everything worked on the last version. I attach a photo from the Dependencies-walker program

if you compare the screen capture you shared with mine, you can see that either the libraries are not found, or you simply did not run DependenciesGui as described.

  • launch run_salome_shell.bat
  • in that shell cd to the directory in which you installed Dependencies walker and type: DependenciesGui
  • in the dependencies GUI, window, upload the NETGENEngine.dll to see if some dependencies are broken (see screen capture below)

Good afternoon! Thank you for explaining in more detail. I have everything according to your screenshot :man_shrugging:

Thanks for the feedback.
Given that you can install SALOME without being administrator, you can simply install locally SALOME 9.9 and check if if you experience the same issue.

1 Like

Hello @NabilG I am facing the same issue:
in salome 9.10 installed in w10. I have run the installer as administrator.
EDIT: found the error, I installed the newer version of visual studio Latest supported Visual C++ Redistributable downloads | Microsoft Learn