SALOME 9.11 installation issue on Ubuntu 22.04

Dear All,
I am trying to launch Salome 9.11 on Ubuntu 22.04 and it does not work. I have downloaded SALOME-9.11.0-native-UB22.04-SRC ec62885173c137ca0fcb09c4597e23a8.tar.gz, unzipped the archive and when I go in the folder and launch ./salome, i have the following message which appears :

ERROR:salomeContext:Unexpected error:
Traceback (most recent call last):
File “/home/pierre/Documents/SALOME-9.11.0-native-UB22.04-SRC/BINARIES-UB22.04/SALOME/bin/salome/”, line 294, in _startSalome
res = getattr(self, command)(options) # run appropriate method
File “/home/pierre/Documents/SALOME-9.11.0-native-UB22.04-SRC/BINARIES-UB22.04/SALOME/bin/salome/”, line 381, in _sessionless
import setenv
File “/home/pierre/Documents/SALOME-9.11.0-native-UB22.04-SRC/BINARIES-UB22.04/KERNEL/bin/salome/”, line 26, in
from launchConfigureParser import verbose
File “/home/pierre/Documents/SALOME-9.11.0-native-UB22.04-SRC/BINARIES-UB22.04/KERNEL/bin/salome/”, line 31, in
from salome_utils import verbose, getPortNumber, getHomeDir
File “/home/pierre/Documents/SALOME-9.11.0-native-UB22.04-SRC/BINARIES-UB22.04/KERNEL/bin/salome/”, line 39, in
import psutil
ModuleNotFoundError: No module named ‘psutil’

I thought about an issue with the dependency, so i ran the following command in the sat folder :
./sat config SALOME-9.11.0-native --check_system

and i obtain :
/usr/bin/env: «python»: Aucun fichier ou dossier de ce type (in French)

I am a bit stucked… any idea to fix it ?

Thank you !

You need to nstall: python-is-python3.

Hello NabilG,
Thank you for your answer ! I have installed python-is-python3 which allowed me to launch ./sat config SALOME-9.11.0-native --check_system. Thus it was possible to have the list of the package to install to launch salome (the list was a bit long :). Once the packages necessary are installed… it works !
Thank you very much so, problem fixed.


Hi PierreLCV, NabilG

I got the same problem at running ./salome in the terminal, I try to install python-is-python3. but Can you explain the command to execute?

I executed sudo apt-get install python-is-python3, and try to launch ./salome, and still not working, I check the python version about it, and Python is 3.10.13 and for Python3 is 3.10.13, do I need to Install more extentions to run ./salome?

To check everything, I read at READ ME file, to launch:
./sat/sat config SALOME-9.11.0-native --check_system

At terminal answer was:

Error :
linux_distribution was removed from platform module in Python 3.8+
For python 3.8+ sat requires distro module to get information on linux distribution.

Did you have the same problem ?



Deat afsilveravi,
I am sorry I did not faced to this issue… However, it appears that install python-is-python3 was not enough for me to be able to launch SALOME. But after installed all the packages necessary it worked. For my side, the command
./sat config SALOME-9.11.0-native --check_system
gave me the list of packages to install and after that it worked…
What do you have when you try to run ./salome ?

Best regards,

Hi Pierre,
I’m trying to install/run Salome 9.11 on Kubuntu 22.04.
I’m, trying to run

in the Konsole, but it does not work.
Could you please indicate me, where do I have to run this command?

Thanks in advance, Max

Dear Max,
Thank you for your message !
Which error do you have when you run
./sat config SALOME-9.11.0-native --check_system
from the relevant folder ?

Thank you !

Hi Pierre, thanks for your quick reply!

This is my console output from bash in Kubuntu 22.04:

happy@happyhippo:~/SALOME/SALOME-9.11.0$ ./sat config SALOME-9.11.0 --check_system
bash: ./sat: Is a directory

(As a sidenote, when I try to run salome from bash with ./salome,
then it appears to start, a splashcrenn shows briefly, and it hoes away and thats all.)

Sorry Pierre, it has worked now.
I went into the sat subfolder and tried again the same command.
Anyway, thanks for your reply ::-):

Dear All,

Typing this command

./sat config SALOME-9.11.0-native --check_system

I got this message:

/usr/bin/env: ‘python’: No such file or directory

I bet python is installed on the system, not as user. But this is just a bet. :expressionless:
Do you know how to change the path? What to install?

Greetz LM

python3 is in fact installed in /usr/bin/python3

I have tried the apt-cache show python-is-python3 command, but didn´t solved the issue.

my colleague has the same path /usr/bin/python3 , which works properly in his working station! Weird :roll_eyes:

Any idea?

Note the message I obtain when I run salome is the following

No module named ‘salomeContextUtils’

Dear Lumasci,
Your error message is very weird… Have you tried to reinstall python and python-is-python3 ?
Have you tried to run another python code with:

Good luck :slight_smile:

Dear @PierreLCV
I did reinstall python and python-is-python3 and run python3 The code runs properly.

I tried to install version 9.12. Now it turns that I have t he following message:

SALOME_Session_Server_No_Server: error while loading shared libraries: cannot open shared object file: No such file or directory

:expressionless: :expressionless:

you need to install the system package which ships this library, namely libqwt-qt5-6. More generally, to find which package ships a .so which is reported as not found, install apt-file tool and run:
apt-file find /usr/lib/

Here: libqwt-qt5-6: /usr/lib/