Salome 9.11.0 does not launch on CentOS 7 HPC cluster

I cannot launch salome 9.11.0 (CentOS 7 flavour), using mesa_salome script, on my CentOS 7 HPC cluster (with XVNC session). Error message is the following:

SALOME_Session_Server_No_Server: error while loading shared libraries: cannot open shared object file: No such file or directory

I have installed all required dependencies (sat), except devtoolset-8-gcc which is compile time dependency.

Salome 9.9.0 and 9.10.0 (CentOS 7 flavour) works fine.

From release notes, NLopt (non-linear optimisation library) is used by ADAO only. I have tried to deactivate ADAO and nlopt in mesa_salome script, without success during lauching.

I have not found such a problem in this forum.

Could you please help me?

I also found that Salome 9.11.0 Linux universal flavour works fine on this CentOS 7 HPC cluster. I know this is built on CentOS 7. It could be fine for my raw usage, but I would like to install a new module, and I need this CenOS 7 flavour.

I finally managed to install my optional module using the ‘Linux universal’ flavour. Thus my request is not critical.

this is obviously a bug. It seems that system nlopt is picked up instead of the embedded one:
you can either install the system one:
and move forward or, since you have access to the universal archive, try to copy in GUI/bin/salome the which is present in BINARIES-CO7/system_deps

Thank you for these 2 solutions. The first one works, as EPEL repository is available on my HPC cluster, second one not (I have tried this first).

Please note that another (only one) library is still missing :, which is easily solved with the same system installation procedure of the EPEL-based cminpack.x86_64 package (

Installing these 2 dependencies is sufficient in order for Salome to launch.

Best regards,
Loïc Chevallier.

1 Like