OpenGL problem - Salome crashes on Windows due to OpenGL version error

I make a fresh install of Salome for Windows 11 (HP laptop, Intel Iris Xe Graphics card), create some geometry, go to MESH, then choose Create Mesh / NetGen 1D-2D-3D, 3D parameters icon. Now, the panel with selection of mesh density etc. does not open. Instead, Salome crashes with a message:

OpenGL context reports version 4.6 but does not export required functions for 4.5 (glGetnTexImage).
Please report this issue to OpenGL vendor „intel”.

I encountered a very similar problem before. At first, it was a Windows 10 system with Salome 9.9 through 9.11 (I tested different releases). The program crashed at the same moment as described above (yet it did not produce any error message, just closed). Interestingly, it STARTED working the next day, even if I did not change anything - perhaps it was due to some system updates?

Is it a known problem? Is there a fix for that?
Regards and thanks in advance

Quite hard to guess here, but do you experience the same issue with: run_mesa_salome.bat (which basically embeds some GL DLLs) ?

Thank you for the prompt response.
Following your piece of advice, I tried with run_mesa_salome.bat. The result is almost the same; Salome crashes after trying to open meshing parameters dialog box. In this case, however, it does not produce the OpenGL-related message, just quits.

I solved the issue: it was due to the Intel Iris Xe graphics card driver, which was not the latest one. I downloaded the one from Intel website and Salome Netgen meshing dialog box stopped crashing the software. BTW, the Windows “update driver” option falsely declared that the best driver was already installed.

1 Like