OmniORB package missing

Seems like the package omniorb is missing from ubuntu 20 install folder. And seems like this is an important package to have in order to acheive the graphical user interface. Where can I find the correct one, or the complete source code?

I was also getting the following error which lead me to the same conclusion, omniORB lacks some files in the INSTALL folder provided for Ubuntu 20.04:
omniidl: ERROR!
omniidl: Could not open IDL compiler module

I realized that indeed was not present in the folder SALOME-9.8.0-native-UB20.04-SRC/INSTALL/omniORB/lib

What I did is that I unzipped the omniORB-4.2.3.tar.gz archive present in SALOME-9.8.0-native-UB20.04-SRC/ARCHIVES and then I compiled it using configure then make and then make install

After that omniORB got installed into my /usr/bin/ folder and I could launch Salome


OmniORB is present in the SALOME 9.8.0 Ubuntu 20.04 archive:

SALOME-9.8.0-native-UB20.04-SRC> tree -L 1 BINARIES-UB20.04/|grep omni
├── omniORB
├── omniORBpy

Are you trying to compile ?
If so, you need to proceed as follows:

chmod +x
# check all missing system prerequisites and install them if missing.
./sat config SALOME-9.8.0-native --check_system
# extract omniORB and omniORBpy
./sat prepare SALOME-9.8.0-native -p omniORB,omniORBpy
./sat compile SALOME-9.8.0-native -p omniORB,omniORBpy --clean_all

this will reinstall omniORB.

I have a similar but different problem.
On virtual box with ubuntu 20.04; Salome version Ubuntu 20
I have all the require dependency (I chek with config)
install, prepare, compile, environ, and launcher all seems to work.

But when launching salome I get an error:
ERROR:salomeContext:Unexpected error:
Traceback (most recent call last):
File “/home/q/SALOME-9.8.0-native-UB20.04-SRC/INSTALL/SALOME/bin/salome/”, line 279, in _startSalome
res = getattr(self, command)(options) # run appropriate method
File “/home/q/SALOME-9.8.0-native-UB20.04-SRC/INSTALL/SALOME/bin/salome/”, line 354, in _runAppli
import setenv
File “/home/q/SALOME-9.8.0-native-UB20.04-SRC/INSTALL/KERNEL/bin/salome/”, line 26, in
import orbmodule
File “/home/q/SALOME-9.8.0-native-UB20.04-SRC/INSTALL/KERNEL/bin/salome/”, line 31, in
from omniORB import CORBA
ModuleNotFoundError: No module named ‘omniORB’

omniORB directory is present in both INSTALL and SOURCES

I tried NabilG solution without sucess.

I attched my terminal output.
salome_launch_error.txt (28,0 Ko)

just to be sure, can you compile omniORB with the attached script which fixes one issue in omniORB compilation script. Basically download the attached script and do:

cp PROJECT/products/compil_scripts/
chmod u+x PROJECT/products/compil_scripts/
./sat prepare SALOME-9.8.0-native -p omniORB,omniORBpy
./sat compile SALOME-9.8.0-native -p omniORB,omniORBpy --clean_all

then, try to import:

./salome context
import omniORB

this will in principle try to import this file:


In addition, you can check that all .so references are found with ldd, e.g

cd INSTALL/omniORB/lib/python3.8/site-packages

Let us know if this helps. (1.1 KB)

Well, it’s seems to be worse than before.
It, fail during compilation, and I can no longer find the 2 omniORB file in INSTALL.
(the file are still there in ARCHIVE and SOURCE).
the terminal output.
salome_launch_error2.txt (2,6 Ko)

omniORB is missing from INSTALL directory since compilation failed. Since omniORB is a prerequisite of omniORBpy, the latter is also not present in INSTALL.
So: can you share LOGS/omniORB/script ?
It contains basically the log and will help to understand what’s wrong in your case - rename it to say: ominORB.txt such that you can upload it.

I did look in my back up INSTALL file.
I found the `INSTALL/omniORB/lib/python3.8/site-packages/omniORB/ with several code file.
But the was missing.

here the log file I tried several thing after so there may be additional information.
script.txt (29,9 Ko)

from your log file, Python.h seems not to be found:
<command-line>: fatal error: Python.h: Aucun fichier ou dossier de ce type

Check that python3-dev is installed on your node, otherwise install it with
sudo apt-get install python3-dev

I tried to install python3-dev.
This didn’t change anything.

can you share your new file: LOGS/omniORB/script ?
In addition, can you do:
apt list --installed > UB20.txt
and share this file, we can then check what is missing on your side.

here the file
The LOGS seems identical.
UB20.txt (163,0 Ko)
script.txt (29,9 Ko)

Ok, i will compare your UB20.txt to what we have later.
But, indeed, in your log file, you seem to use Python2 since one can see in your log file references to Python2: -I/usr/include/python2.7

Can you set python3 as python (see at this link) ?

as a quick test, you can also simply do the following:

ln -s /usr/bin/python3 python
export PATH=$PWD:$PATH
./sat compile SALOME-9.8.0-native -p omniORB,omniORBpy --clean_all

and then rerun the commands. But better setup things once for all. I will later send you the missing system products by comparing our UB20 build node to your UB20.txt

After setting python 3 as default, typing your quick test.
Everything work.
Thanks a lot.

Dear all,

I tried to install Salome.9.9.0 on Ubuntu 22.04 following the instructions in the README file. I also encountered the same error about ‘_omniorbpy’ is missing.

I attached two text files which show the steps I followed, and UB20.txt to show if anything missing.

I highly appreciate any help.

UB20.txt (177.8 KB)
Salome_installation_steps_I_followed.txt (3.6 KB)

I failed to install UB20 version on Ubuntu 22.04. Linux Universal version however worked right away.

Hi, I have pretty much the same problem on Debian Bullseye. I have downloaded and unpacked SALOME-9.9.0-native-DB11-SRC.tar.gz , run

sat/sat config SALOME-9.9.0-native --check_system

which told me which packages to install - here the first problem surfaced: it wanted package “fftw” but no package with that exact name is available in this distribution. I installed python3-fftw3 which may or may not be the right one from the many choices and tried to proceed:

ERROR:salomeContext:Unexpected error:
Traceback (most recent call last):
File “/home/rz/salome/SALOME-9.9.0-native-DB11-SRC/BINARIES-DB11/SALOME/bin/salome/”, line 281, in _startSalome
res = getattr(self, command)(options) # run appropriate method
File “/home/rz/salome/SALOME-9.9.0-native-DB11-SRC/BINARIES-DB11/SALOME/bin/salome/”, line 368, in _sessionless
import setenv
File “/home/rz/salome/SALOME-9.9.0-native-DB11-SRC/BINARIES-DB11/KERNEL/bin/salome/”, line 26, in
import orbmodule
File “/home/rz/salome/SALOME-9.9.0-native-DB11-SRC/BINARIES-DB11/KERNEL/bin/salome/”, line 31, in
from omniORB import CORBA
File “/home/rz/salome/SALOME-9.9.0-native-DB11-SRC/BINARIES-DB11/omniORB/lib/python3.9/site-packages/omniORB/”, line 44, in
import _omnipy
ModuleNotFoundError: No module named '_omnipy

TIA for an yhelp

I think the problem may be that I have a mixed 32/64 bit system, the precompiled modules are available only for 64 bit. Unfortunately switching python version from 32 to 64 bit isn’t easy.

can you share the output of apt list --installed command such that we can compare to what we have ?
apt list --installed |tee DB11.txt
and upload this file