ModuleNotFoundError: No module named 'psutil'

I think that I followed the instructions. I have extracted SALOME-9.10.0-native-UB22.04-SRC-0c94e450345289979aeca2f80929ad2e.tar.gz and changed to the SALOME-9.10.0-native-UB22.04-SRC
I ran ./sat/sat config SALOME-9.10.0-native --check_system once and copied all of the require package names into sudo apt-git install "pasted space delimited package list here.

I gain ran ./sat/sat config SALOME-9.10.0-native --check_system and now all required packages were marked ok including - python3-psutil : OK.

Then I tried to run ./salome but got the following:

Traceback (most recent call last):
File “/home/bjacks3rd/projects/Salome/SALOME-9.10.0-native-UB22.04-SRC/BINARIES-UB22.04/SALOME/bin/salome/”, line 281, in _startSalome
res = getattr(self, command)(options) # run appropriate method
File “/home/bjacks3rd/projects/Salome/SALOME-9.10.0-native-UB22.04-SRC/BINARIES-UB22.04/SALOME/bin/salome/”, line 368, in _sessionless
import setenv
File “/home/bjacks3rd/projects/Salome/SALOME-9.10.0-native-UB22.04-SRC/BINARIES-UB22.04/KERNEL/bin/salome/”, line 26, in
import orbmodule
File “/home/bjacks3rd/projects/Salome/SALOME-9.10.0-native-UB22.04-SRC/BINARIES-UB22.04/KERNEL/bin/salome/”, line 30, in
from nameserver import NamingServer
File “/home/bjacks3rd/projects/Salome/SALOME-9.10.0-native-UB22.04-SRC/BINARIES-UB22.04/KERNEL/bin/salome/”, line 26, in
from server import Server
File “/home/bjacks3rd/projects/Salome/SALOME-9.10.0-native-UB22.04-SRC/BINARIES-UB22.04/KERNEL/bin/salome/”, line 25, in
from salome_utils import getHostName
File “/home/bjacks3rd/projects/Salome/SALOME-9.10.0-native-UB22.04-SRC/BINARIES-UB22.04/KERNEL/bin/salome/”, line 39, in
import psutil
ModuleNotFoundError: No module named ‘psutil’

I have run import psutil in pyhon3 but it says not found.

I have run sudo apt-get install -y pthon3-psutil but I get,
python3-psutil is already the newest version (5.9.0-1build1)

I have other open source projects installed that also have python installed so I wonder if the wrong python installation is being run when I run ./salome.

for example if I run- which python in terminal i get /home/bjacks3rd/mambaforge3/bin/python which where my Moose framework is installed.

I have started to unravel the problem but still stuck.
So far I have done several pip3 installs :slight_smile:
pip3 install psutil
pip3 install packaging
pip3 install PyQt5

an now have salome running, however i still have a traceback error:
Traceback (most recent call last):
File “/home/bjacks3rd/projects/Salome/SALOME-9.10.0-native-UB22.04-SRC/BINARIES-UB22.04/GUI/lib/python3.10/site-packages/salome/”, line 94, in
import SalomePyQt
ImportError: /home/bjacks3rd/mambaforge3/lib/python3.10/site-packages/PyQt5/ undefined symbol: _ZdaPvm, version Qt_5
so far I don’t know how to fix this

from what I read, you have a non standard PyQt5 installation.
In principle, you need to install on your Ubuntu 22, with apt, these packages: