Issue with installing salome on ubuntu 22.04

I’m trying to install salome on VirtualBox Ubuntu 22.04 (Salome version Ubuntu 20)
everything work until the compile phase when some module does’nt compile.

here an exemple :

mahefpc@mahefpc-VirtualBox:~/SALOME-9.8.0-native-UB20.04-SRC$ ./

Warning: INSTALL already exists! Please rename or delete it before executing this script

mahefpc@mahefpc-VirtualBox:~/SALOME-9.8.0-native-UB20.04-SRC$ ./sat config SALOME-9.8.0-native

mahefpc@mahefpc-VirtualBox:~/SALOME-9.8.0-native-UB20.04-SRC$ ./sat prepare SALOME-9.8.0-native -p omniORB,omniORBpy

Clean the source directories …OK

Getting sources of the application SALOME-9.8.0-native

workdir = /home/mahefpc/SALOME-9.8.0-native-UB20.04-SRC/salomeTools/…

omniORB: arc:/home/mahefpc/SALOME-9.8.0-native-UB20.04-SRC/ARCHIVES/omniORB-4.2.3.tar.gz … OK

omniORBpy: arc:/home/mahefpc/SALOME-9.8.0-native-UB20.04-SRC/ARCHIVES/omniORBpy-4.2.3.tar.gz … OK

Getting sources of the application: OK (2 / 2)

Patching sources of the application SALOME-9.8.0-native

workdir = /home/mahefpc/SALOME-9.8.0-native-UB20.04-SRC/salomeTools/…

Patching sources of the application: OK (2 / 2)

mahefpc@mahefpc-VirtualBox:~/SALOME-9.8.0-native-UB20.04-SRC$ ./sat compile SALOME-9.8.0-native -p omniORB,omniORBpy

Executing the compile commands in the build directories of the products of the application SALOME-9.8.0-native

SOURCE directory = /home/mahefpc/SALOME-9.8.0-native-UB20.04-SRC/salomeTools/…/SOURCES

BUILD directory = /home/mahefpc/SALOME-9.8.0-native-UB20.04-SRC/salomeTools/…/BUILD

Compilation of omniORB … KO

Compilation of omniORBpy … ERROR : the following mandatory product(s) is(are) not installed: omniORB

Compilation: KO (1/2)


UB22.04 , which was released about a month ago, is not yet supported.
You can either use the universal binary (read carefully the README file about uncommenting some lines in SALOME launcher if needed) or try to compile it by yourself and share your experience.
To understand the issue about omniORB compilation reported by SAT, you can look at file LOGS/omniORB/script.

Any update on this issue? I also tried installing Salome (9.9.0) on Ubuntu 22.04 and failed the same way. Any suggestion on how can I procede?

I was new to Salome and didn’t notice there was Linux Universal version. I downloaded and run it without any change on both Ubuntu 22.04 and wsl (win11). Both worked. I wanted to give this feed back incase it might be useful to someone else.