Installation problem with SALOME-9.9.0-UB18.04-SRC

Hi, I run ubuntu 18.04. I downloaded SALOME-9.9.0-UB18.04-SRC.tar.gz and extracted it to /opt/Salome9_9 and then tried to launch:

tar xfz SALOME-9.9.0-UB18.04-SRC.tar.gz

I then get the error:
SALOME_Session_Server_No_Server: error while loading shared libraries: cannot open shared object file: No such file or directory

I assume I have some missing PREREQUISITES. I then tried to find out what was missing with:
sat config SALOME-9.9.0 --check_system

I then get the error:
Failed to import the site module

Traceback (most recent call last):

File “/opt/Salome9_9/SALOME-9.9.0-UB18.04-SRC/BINARIES-UB18.04/C3PO/lib/python3.6/site-packages/”, line 73, in


File “/opt/Salome9_9/SALOME-9.9.0-UB18.04-SRC/BINARIES-UB18.04/C3PO/lib/python3.6/site-packages/”, line 22, in __boot


File “/opt/Salome9_9/SALOME-9.9.0-UB18.04-SRC/BINARIES-UB18.04/Python/lib/python3.6/”, line 544, in


File “/opt/Salome9_9/SALOME-9.9.0-UB18.04-SRC/BINARIES-UB18.04/Python/lib/python3.6/”, line 530, in main

known_paths = addusersitepackages(known_paths)

File “/opt/Salome9_9/SALOME-9.9.0-UB18.04-SRC/BINARIES-UB18.04/Python/lib/python3.6/”, line 282, in addusersitepackages

user_site = getusersitepackages()

File “/opt/Salome9_9/SALOME-9.9.0-UB18.04-SRC/BINARIES-UB18.04/Python/lib/python3.6/”, line 258, in getusersitepackages

user_base = getuserbase() # this will also set USER_BASE

File “/opt/Salome9_9/SALOME-9.9.0-UB18.04-SRC/BINARIES-UB18.04/Python/lib/python3.6/”, line 248, in getuserbase

USER_BASE = get_config_var('userbase')

File “/opt/Salome9_9/SALOME-9.9.0-UB18.04-SRC/BINARIES-UB18.04/Python/lib/python3.6/”, line 601, in get_config_var

return get_config_vars().get(name)

File “/opt/Salome9_9/SALOME-9.9.0-UB18.04-SRC/BINARIES-UB18.04/Python/lib/python3.6/”, line 550, in get_config_vars


File “/opt/Salome9_9/SALOME-9.9.0-UB18.04-SRC/BINARIES-UB18.04/Python/lib/python3.6/”, line 421, in _init_posix

_temp = __import__(name, globals(), locals(), ['build_time_vars'], 0)

ModuleNotFoundError: No module named ‘_sysconfigdata_m_linux_x86_64-linux-gnu’

What can I do next? should I install libgeos-dev and hope that that resolves my issue? or is there a more instrumental approach to troubleshoot this?


can you try first to install libgeos-c1v5 and try to run SALOME again ?

apt-file find /usr/lib/x86_64-linux-gnu/
libgeos-c1v5: /usr/lib/x86_64-linux-gnu/
apt install libgeos-c1v5

OK, thank you, installing libgeos-c1v5 seem to have solved the problem.