How to build HELLO.dll and HELLOEngine.dll for Hello Module in Salome

Hello NabilG,

I got it. It is in the file.


In addition to the SalomeApp.xml file, you can have a look at HELLOGUI.cxx and HELLO_msg_en.ts
but note that core implementation is done in GUI (you can build GUI and HELLO in debug mode and follow step by step what happens when clicking or hovering on the icon.

Great work done by SALOME developers.

Hi NabilG,

I used the same procedure to build and install GUI module but it doesn’t install the GUI module in W64 folder.

call SALOMEConfigTool.bat --application SALOME-9.12.0 --use-gitpub --products CONFIGURATION,GUI

call “C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Auxiliary\Build\vcvarsall.bat” x64

SALOME-9.12.0\W64\Python\python.exe SAT\sat compile SALOME-9.12.0 -p GUI,CONFIGURATION --clean_all

Do I use above command lines or something different?
Any idea?


You need to look at makeinstall script in LOGS/GUI/
and share the file .

Hi NabilG,

Attached is the makeinstall LOG file. I noticed it is looking for the cmake_install.cmake file in the wrong location.

Can you share which file sets this path?

makeinstall.txt (302.9 KB)


From the log file, the error says that you need to switch off documentation generation as read from makeinstall file. See this thread SF-1183.

In addition, it seems that the directory in which you installed SALOME leads to PATH variable length which is too long. You might experience PATH length issue at runtime.
You should use something like: C:\S

CMake Error at doc/salome/gui/cmake_install.cmake:40 (file):
    file INSTALL cannot find
    File exists.
  Call Stack (most recent call first):
    doc/salome/cmake_install.cmake:38 (include)
    doc/cmake_install.cmake:37 (include)
    cmake_install.cmake:83 (include)

After switching off documentation generation, I got the same error.
I also relocated Salome-9.12.0 project to C:\S folder.
makeinstall.txt (257.4 KB)

The cmake option needs to be set in default_win section of GUI.pyconf.

After properly switching off documentation generation, I still get the same error.

makeinstall.txt (257.4 KB)

Try removing BUILD/GUI then rerun compilation.
If it still fails share contents of GUI.pyconf

Note that you can switch documentation in CMakeLists.txt at root of GUI directly at this line:

After removing BUILD/GUI folders, it still fails.
Attached is the GUI.pyconf file.
GUI.pyconf.txt (8.8 KB)

This is weird. Can you share file LOGS\GUI\cmake as well as file SAT\data\local.pyconf

As a final suggestion, I would simply replace:

in CMakeLists.txt file at root of GUI.

When disabled documentation generation directly from the CMakeLists.txt file, MAKE was not successfully compiled.

Attached are the cmake log and local.pyconf files by switching off -DSALOME_BUILD_DOC=OFF in GUI.pyconf.

cmake.txt (41.8 KB)
local.pyconf.txt (343 Bytes)


Can you confirm that you compile GUI as it is , namely without any changes?
It is rather strange because the documentatìon generation should not occur since switched off.
I will try it on my side and get back to you.

Yes. I am compiling the GUI as is. No changes.

Hi NabilG,

Do you have a chance to compile the GUI module?


Hi NabilG,

I was able to compile the GEOM module successfully but not the GUI.


Hi Kevin,
I did not have the time to look at it yet. I will check this friday and share the output.

Hi NabilG,

I also tried to compile another module called SMESH. I got the same install error as the GUI module.


1 Like

I also get same error.When I switch OFF the SALOME_BUILD_DOC the logs show link errors. If I switch ON logs show INSTALL error. I have set latex to the path but it always show error.