FileChooser window freezing when opening or importing files

I run salome 9.11.0 on windows 10. When I try to open a file or import a brep for instance, the filechooser window is very slow and/or freezes.
At start-up, the following warning is displayed in the console : “WRN - The configuration file has not been found, using default parameters.”
I have no zip files at the root level of hard drive and no disconnected letter drives.
Any idea ?

I will prepare an instrumented DLL which I will upload later today.
In the meanwhile, can you please send us the output for the following commands that you can run in a cmd terminal (type cmd in the windows search bar to start a cmd terminal).

  • information about your graphics card
wmic path win32_VideoController get name, videoarchitecture, deviceID, adapterram
  • information about your windows version:
  • output of this command line showing your environment variables (remove any sensitive information before sharing this output):
  • SALOME installation directory


Thank you Nabil,

Salome installation folder is C:\SALOME-9.11.0 but I have tried other locations and I still have the same problem.

Windows version is 10.0.19045.3803.

Graphic card :
AdapterRAM DeviceID Name VideoArchitecture
4293918720 VideoController1 NVIDIA RTX A1000 6GB Laptop GPU 5
VideoController2 Citrix Indirect Display Adapter 5
1073741824 VideoController3 Intel(R) Iris(R) Xe Graphics 5

Hi Karim,
given you’re at CEA, we just sent you all relevant information which will hopefully help to understand what is going behind the scene here.

We will share the solution once this issue is fully understood on SALOME forum.


it seems to be related to this qt bug report about retrieving icons.

A workaround is to add in run_salome.bat:


Or, so that it works when you click on the lamp icon, if you have installed SALOME through the install wizard, edit the salome file and add:

    context.setVariable(r"QT_QPA_PLATFORMTHEME", "void")

line 105 for instance.


Dear cbourcier,

I’m having the same problem while opening Salome. “WRN - The configuration file has not been found, using default parameters.”
I installed it in Windows.
I tried what you suggested and didn’t work.
Do you have another suggestion?

Best Regards

Dear Virna,

This warning message is not related to the issue reported here when opening files on Windows.

Does the file chooser dialog box open eventually? Does it have blue icons? The icons should be blue after having appied the fix QT_QPA_PLATFORMTHEME.