Error during Salome launch on CentOS7 cluster machine

Hello,

I unpacked SALOME Linux CentOS 7 64-bits in a CentOS 7 machine that has python 3.8.5.

When I run the salome script to start an instance on the shell I get the error below.

[b@p SALOME-9.7.0-MPI-CO7-SRC]$ python3 salome
runSalome running on CO7machine
Searching for a free port for naming service: 2810 - OK
Searching Naming Service + found in 0.1 seconds
Searching /Kernel/Session in Naming Service ++++Warning, no type found for resource “localhost”, using default value “single_machine”
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++Traceback (most recent call last):
File “/SAN/uclic/ammdgop/SALOME-9.7.0-MPI-CO7-SRC/BINARIES-CO7/KERNEL/bin/salome/orbmodule.py”, line 181, in waitNSPID
os.kill(thePID,0)
ProcessLookupError: [Errno 3] No such process

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/SAN/uclic/ammdgop/SALOME-9.7.0-MPI-CO7-SRC/BINARIES-CO7/KERNEL/bin/salome/runSalome.py”, line 694, in useSalome
clt = startSalome(args, modules_list, modules_root_dir)
File “/SAN/uclic/ammdgop/SALOME-9.7.0-MPI-CO7-SRC/BINARIES-CO7/KERNEL/bin/salome/runSalome.py”, line 639, in startSalome
session=clt.waitNSPID("/Kernel/Session",mySessionServ.PID,SALOME.Session)
File “/SAN/uclic/ammdgop/SALOME-9.7.0-MPI-CO7-SRC/BINARIES-CO7/KERNEL/bin/salome/orbmodule.py”, line 183, in waitNSPID
raise RuntimeError(“Process %d for %s not found” % (thePID,theName))
RuntimeError: Process 63029 for /Kernel/Session not found

— Error during Salome launch —

I suspect there must be a dependency missing but I would need to check the error messages and I don’t have sudo access to the logs.

How can I debug the process to know what is going wrong?

Would you be able to provide support to get SALOME running on the shell?

Many thanks,
Francisco

Hello,

you can check if some system packages are missing with:

./sat config SALOME-9.7.0-MPI --check_system

and install them (skip those with -devel if you just want to use salome, not developping in it).

You can also try the univeral binary which contains all needed runtime dependencies.

Christophe

Hi Christophe

thank you for your reply.

I ran the sat command as you recommended. Then I installed the missing run time dependencies that it returned as result. I ran the sat command again to make sure there were no run time dependencies missing. I run ./salome and got the exact same error.

I also tried to install the universal binary as you suggested and run ./salome. Same result…

Not sure how to proceed from here. Any other way to diagnose what is failing?

Many thanks.
Francisco

It may be because of an old issue with the hostname not defined on your computer. Check it with:
hostname -f

It should display the name of your computer and of your network domain.

If it does not, edit /etc/hosts and check that there are at least these 2 lines (if not, add them with the name of your computer and your domain on the second line):

127.0.0.1       localhost localhost.localdomain
127.0.0.1       machine_name machine_name.domain_name

Otherwise, it can be an error when displaying the graphic interface. Check if other applications with graphic interface can be launched. It can occur when working with ssh without having forwarded the display.
You can try to launch Paraview from SALOME environment with:

salome context
paraview

Christophe

Hi Christophe,

thank you for you time.

‘hostname’ -f does return the name of the server that I am working on.

When I check ‘/etc/hosts/’, I find the first line but not the second. Instead, ‘machine_name’ and ‘machine_name.local’ point to another IP, like so:

‘128.16.3.19 machine_name machine_name.domain_name’

Should it be configured with the loopback address?

Also it might be useful to mention that I am trying to run salome in a cluster node. AFAIK it may not have a graphic environment at all. Would a display be a necessary condition to run SALOME?

My use case is to run python scripts against a salome instance to procedurally generate geometries and meshes. I am able to do it in my local machine but now I need to scale up the process. Hence I’m moving it in to a cluster.

Many thanks,
Francisco

Hi Francisco,

indeed, on a cluster node, you should launch Salome in batch mode:

./salome -t -w1 your_script.py

or try to use the new session-less mode to launch python scripts without launching salome.

Some clusters also provide graphic nodes (with dedicated graphic cards) where we can launch software with graphic interface, usually in a remote desktop (TurboVNC, NICE, HPCDrive…).

Christophe

1 Like

Hi Christophe,

I ran Salome in batch mode with the command you provided and it is now working nicely.

Thank you so much!

Best,
Francisco