Can't save file with SALOME V9.11 on ArchLinux

Hi, I’m having trouble getting any SALOME file saved, each time I try to save my progress I get this error : "

Can’t save file “/home/CovLeVrai/My_folders/SALOME/native/tudddd.hdf”.
Possible reasons:

  • permission denied;
  • unsufficient disk space;
  • application error.
    Try to use another file name.

I did some research and I found this : , which is basically the exact same issue I have but on Windows 10… (it didn’t work for me)

I don’t think it’s a permission problem because I managed to run SALOME as root and the error persisted.
I have plenty of disk space and I’m not even trying to save a big file.
I tried to use different names.
The only thing that I didn’t try to fix is that I’m launching SALOME with “mesa_salome” because the standard one doesn’t work and I don’t know how to make it work…
if you know how to fix it or if there is the solution somewhere please tel me.

Edit: here are my OS’s specs: "
OS: Arch Linux x86_64
Host: Laptop (12th Gen Intel Core) A6
Kernel: 6.6.5-arch1-1
Uptime: 13 days, 3 hours, 14 mins
Packages: 1065 (pacman), 7 (flatpak)
Shell: bash 5.2.21
Resolution: 2256x1504
DE: Hyprland
Theme: Adwaita [GTK3]
Icons: Adwaita [GTK3]
Terminal: kitty
CPU: 12th Gen Intel i7-1260P (16) @ 4.700GHz
GPU: Intel Alder Lake-P GT2 [Iris Xe Graphics]
Memory: 18368MiB / 64016MiB

OK after some more research I found this which was my issue and it worked on V9.11 !