Can't open HDF in RO mode

Hi Salomers,

I encountered recently a problem when using SALOME 9.7.0 or 9.8.0 on CentOS 7. After downloading the corresponding version and unpacking the tar file, I load salome environment by env_launch.sh and launch it later without any problem. However, I got a problem when I want to read a .hdf file
image

and an error message in terminal was shown “Can’t open HDF in RO mode”. But I checked the hdf file itself, it is not in RO mode, I tried to change the mode with option 777, it didn’t help. I didn’t find any relevant discussion in the forum. Can anyone help me on this?

Thanks in advance!

Hi,
I tried on one CentOS 7 node at hand and did not manage to reproduce the reported issue
I created a study, saved it as an HDF file and was able to reopen it.
Even if this is not recommended, I tried several directories names 'with spaces, special characters) and was not able to reproduce.
Are you opening the study from a mounted disk or a local disk ?

Hi NabilG,
Thanks for your reply.
It is opened from a remote CentOS 7 node, I am not sure if it uses local disk or mounted disk.

I can create a study, and save it as an HDF, the only problem is I cannot reopen it later, and this HDF file can be opened normally in Windows version or Ubuntu version.

Is there any other information I can provide to identify the problem?

Thanks a lot

Hi ,
it’s rather difficult to guess what is going on here. What do you mean with:

It is opened from a remote CentOS 7 node

are you running SALOME remotely (via ssh for instance) ? If this is the case, better use mesa_salome launcher.
In addition, does this occur with SALOME only or with other applications as well?

Bonus; to know if a disk is local or mounted, you could try to use the Linux stat utility, e.g.:

stat --file-system --format="%T" /home//*
nfs

stat --file-system --format="%T" /tmp
ext2/ext3

Hi NabilG,

Thanks!!!

I am using SALOME remotely via NICE DCV client. I tried both salome or mesa_salome, no evident difference was captured. I had only this problem with SALOME, other applications work well to read or write files.

Indeed, SALOME can load python script or dump study in .py format, it also can save the study in HDF, but it cannot reopen it later (no idea where it comes from this RO issue) …

stat --file-system --format="%T" /home/
xfs

stat --file-system --format="%T" /my working directory where SALOME installed
lustre

stat --file-system --format="%T" /tmp
ext2/ext3

I uploaded a SALOME archive which implements a debug version for hdf5 and KERNEL which might be useful to get some additional information about what is going on behind the scene.
You can download the instrumented SALOME version by running:
wget ftp://ftp.cea.fr/incoming/y2k01/sf-85/SALOME-9.8.0-CO7.tar.gz
and share the error message if any.
Note as it was mentionned to me by Vadim, it might well be an issue of HDF5.
HTH.

Thanks Nabil.

The server I used is closed temporally until this Friday, I will share the error message with you once it is opened.

Hallo,

sorry ich schreibe in deutsch.
Habe das selbe Problem. In Version 9.8.0 gespeicherte *.hdf Dateien ergeben beim lesen den Fehler “cannot open document”.
Nur Dateien im Format *.py werden korrekt eingelesen.

Alte Dateien *.hdf von Salome 9.7.0 werden korrekt von Version 9.8.0 gelesen.

Danke fuer Antwort

Luve

Hallo

Weitere Info:
System WIN10
Salome 9.8.0 installiert. Konstruktionen unter shaper werden gespeichert. Reopen ist nicht moeglich. Soweit bekannt.
Salome 9.8.0 Konstruktionen unter GEOM werden gespeichert. Reopen ist jetzt moeglich.
Salome 9.7.0 erneut installiert. Konstruktionen unter shaper werden gespeichert.
NEU: Reopen ist nicht mehr möglich!! Wochen frueher, das heisst vor der Installation von Version 9.8.0 funktionierte Salome 9.7.0 korrekt.

Was kann ich jetzt tun?

Danke

Luve

Hi Luve,

what do you mean with Reopen is “nicht moeglich” ?
You mean you can implement a SHAPER study, are able to save it in HDF file format but cannot read it back ?

Can you upload/share your study such that we can check if the issue can be reproduced on our side ?

In addition, can you tell your Windows version e.g. in my case:

systeminfo

Nom du système d’exploitation:              Microsoft Windows 10 Entreprise LTSC
Version du système:                         10.0.17763 N/A build 17763
Fabricant du système d’exploitation:        Microsoft Corporation

MFG,

Hallo

ja das ist richtig verstanden. Die angehängte Datei ist vor einigen Wochen mit Version 9.7.0 erstellt worden. Sie kann nicht mehr mit Verision 9.8.0 geoeffnet werden.

NEU:
Vor der Installation von 9.8.0 hatte ich Version 9.7.0 gelöscht.
Jetzt d.h. später habe ich erneut Version 9.7.0 download. Sie funktioniert auch nicht mehr richtig. Das heisst Im shaper mit Version 9.7.0 erstellte Dateien *.hdf werden gespeichert. Salome schliessen. Salome 9.7.0 wieder oeffnen. Date einladen. Fehlermeldung “can not open document”.

Bitte um Hilfe: Wie kann ich ein Beispiel anhaengen? Dieser Editor verhindert ein upload meines Beispiels. Ich bin fuer den Editor ein neuer Kunde.

Danke

Luve

You can upload the HDF file (your study) by clicking on this button:

This will help to check if your issue can be reproduced.
Regarding the second question about SALOME 9.7
Here is what you can do to ensure that everything is set consistently:

  • start a Windows file browser
  • in the search bar, type: %userprofile%\.config\salome
  • delete all files present in that directory
  • in the search bar, type: %APPDATA%\salome
  • remove all files present in that directory
  • in the search bar, type: %APPDATA%
  • delete all files wich name starts with: .omni
  • delete file: .salome_PortManager.cfg

image

Then, simply download again https://files.salome-platform.org/Salome/Salome9.7.0/SALOME-9.7.0.zip
Extract it in a directory, which does not contain any spaces of special characters, e.g. C:
hth

Hello

the upload does not work. I suspect a forum rule. The german error message: “New users are not allowed to upload files”.
I am apparently still a “new user”.

Is there another way to send the files via email?

I will try your recommendations right away.

Thanks a lot

Luve

translate with Deepl

Hello NabilG

It works Thank you very much for the support.
The clean up was an important hint.
For your information, my previous installations for WIN10 were done with the *.exe file and not *.zip.
Understandable: version 9.7.0 can open files from 9.8.0.

With kind regards

Luve

translate with Deepl