Cannot use primitives or features in Shaper


I cannot use anything in the primitives or features menu within Shaper. They all seem to be disabled with greyed out icons. I tried selecting a sketch to use the extrusion option, this did not work. I restarted the program to try and create a primitive. This also did not work. I couldn’t find any mention of any similar issues when researching both on this forum and the internet at large, and would appreciate suggestions of troubleshooting steps. Looking around in the preferences didn’t turn up anything useful.

Did you create a new part first? It is the Gear icon. This will enable everything normally

This solved the problem. It does however raise a question for me, does it make sense to allow sketching when a part has not been created? If this could be disabled as well without creating some negative impact, I think it would make the software easier to use and less misleading.

Would recommend to follow some tutorials to learn how to use the module