[bug] salome not respectivng preference/Salome/python viewer/font

trying to use a font monospaced, I modified the settings (preference/Salome/python viewer/font) but even after closing the python viewer or salome itself, the font it does not change which I assume that it is a bug.

Hello Franco,
can you precise which version/OS your are using?

I cannot reproduce this.
I tested on Windows with 9.11 & 9.12, and 9.12/master on Debian 10 & 11.
The change happens after validating the Preferences and is still present after restart.


Hello fred,
I am using tuxedOS 3 (debian/ubuntu LTS based system) with kde 6.1, I am using salome master (universal linux) right now in a wayland session (as the one for ubuntu does not work in wayland session).
also, after validating the preferences or restarting it does not modify the python console font